Auteur Sujet: Performance du forum  (Lu 6462 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Darkevil

Re : Performance du forum
« Réponse #45 le: janvier 21, 2012, 09:55:08 am »
Citation de: Moona
Est-ce qu'un serveur perso à l'asso pourrait y remédier?
Avant d'envisager une telle extrémité, il conviendrait de regarder les codes et les scripts qui tournent sur ce serveur.
Yaourt l'a mentionné, il y a une tripoté de problèmes possibles dont les principales causes pourraient provienir du code même d'opale.

Je doute qu'OVH qui mutualise des serveurs pour différents comptes, laisse les performances de leurs serveurs s'effondrer. Et, si c'était le cas, il y a des possibilités d'interagir avec eux pour solutionner ces problèmes.

Un serveur dédié pour l'association pourrait être bien mais il faut en avoir les compétences pour le gérer.
Doktor ès PsyKiatry, O.P.A DireKtor
It's Good to Be Bad
Evil it's Good

Tiocfaidh ár lá

Hors ligne Khadamon

Re : Performance du forum
« Réponse #46 le: janvier 21, 2012, 13:15:27 pm »
Otez moi d'un doute : je vais devoir rééxpliquer tout ce que j'ai déjà dit parce que vous n'avez pas comprit ou parce que vous avez décidé de faire comme si je n'avais rien dit ? :suspect:

- Yaourt se plaît à préciser à de nombreuse reprise que le code SMF d'Opale est à 99,9% celui d'origine ; et ce n'est pas faux depuis la migration en SMF 2.0 et le non report de certaines modifications
- Donc si un problème de code ou de scripts venait à provenir d'Opale, ce serait un problème de SMF ; et pour copier Darkevil : Je doute que SMF, qui est téléchargé à des milliers d'exemplaires, laisse de tel bug de performances sur leur code/script. Et, si c'était le cas, il y a des possibilités d'interagir avec eux pour solutionner ces problèmes : http://www.simplemachines.org/
- Les logs de serveur mutualisé sont assez léger ; et je n'y ai pas vu d'erreur sur les horaires indiqués par Darkevil par exemple ; mais je n'ai pas épluché l'intégralité des logs pour vérifier qu'aucune erreur était véritablement présente hein ... Je ne suis pas fou, j'ai une vie et des obligations en ce moment (AG, tout ça ...)
- En terme de proportion je dirais que vous êtes moins de 1% des utilisateurs à avoir, de manière ponctuel, ce type de problème : c'est acceptable je trouve, même si chiant ; et comme je suis quasi persuadé que de toute façon on ne peux rien faire de notre coté ... Bah ...

Winter is coming
“When the only tool you have is a hammer – all problems look like nails”

Hors ligne Marchiavel

Re : Performance du forum
« Réponse #47 le: janvier 21, 2012, 13:33:47 pm »
   Donc, en synthèse (j'aime bien synthétiser en ce moment, je suis de bonne humeur, j'ai reçu ma commande, je suis joie tout ça), les problèmes d'accès serveurs peuvent être dûs :

      - soit aux serveurs eux-mêmes -> Kha dit avoir regardé les logs serveurs, et n'y avoir rien vu
      - soit au code utilisé pour le forum.

   Les actions possibles sont :

      - contacter OVH pour savoir s'ils ont des problèmes de bande passante/disponibilité, et si oui, quand pensent-ils qu'elles seront résolues,
      - modifier la verbosité des logs serveurs, et continuer à vérifier avec les dates/heures fournies par les victimes,
      - rechercher sur le forum de SimpleMachines si des erreurs de ce genre ont été indiquées et si des solutions y ont été apportées.

   Arrêtez-moi si je me trompe, mais Kha, en tant que Webmaster, pourrais-tu accomplir ces 3 actions, et nous faire un retour :

   1) sur la faisabilité (j'ai un doute sur le fait qu'on puisse modifier la verbosité de serveurs que nous ne gérons pas nous-mêmes), et
   2) sur les résultats de ces investigations

?

   Merci.
/!\ ATTENTION : Opalien dangereux pour la santé ! A fréquenter avec modération /!\

LA Cause du XXIème siècle : SAUVONS LES ROLISTES

Hors ligne Darkevil

Re : Performance du forum
« Réponse #48 le: janvier 21, 2012, 13:35:10 pm »
   Donc, en synthèse (j'aime bien synthétiser en ce moment, je suis de bonne humeur, j'ai reçu ma commande, je suis joie tout ça), les problèmes d'accès serveurs peuvent être dûs :

      - soit aux serveurs eux-mêmes -> Kha dit avoir regardé les logs serveurs, et n'y avoir rien vu
      - soit au code utilisé pour le forum.

   Les actions possibles sont :

      - contacter OVH pour savoir s'ils ont des problèmes de bande passante/disponibilité, et si oui, quand pensent-ils qu'elles seront résolues,
      - modifier la verbosité des logs serveurs, et continuer à vérifier avec les dates/heures fournies par les victimes,
      - rechercher sur le forum de SimpleMachines si des erreurs de ce genre ont été indiquées et si des solutions y ont été apportées.

   Arrêtez-moi si je me trompe, mais Kha, en tant que Webmaster, pourrais-tu accomplir ces 3 actions, et nous faire un retour :

   1) sur la faisabilité (j'ai un doute sur le fait qu'on puisse modifier la verbosité de serveurs que nous ne gérons pas nous-mêmes), et
   2) sur les résultats de ces investigations

?

   Merci.
Pour l'ensemble de tes écrits ci-dessus. :)

Hors ligne Khadamon

Re : Performance du forum
« Réponse #49 le: janvier 21, 2012, 13:58:49 pm »
- contacter OVH : faisable, mais je ne le ferais pas moi-même pour des raisons évidente - ce sera le rôle du prochain Webmaster éventuellement.
My 2 cents : Ca va faire 10 ans que je travail dans le support info/télécom, et vu le %age de touché par le "problème" je suis sûr à 98% que la réponse sera : "Ca arrive, les réseaux bagottent des fois" (bagotter : avoir des soubressauts on/off)
- modifier la verbosité des logs serveurs : Non faisable à ma connaissance
- rechercher sur le forum de SimpleMachines : Idem que pour le contact OVH, idem pour "My 2 cents".


En conclusion :
- Je le ferais si je suis réélu au CA et réélu en tant que Webmaster
- Sinon ce sera au prochain Webmaster de s'en charger
Ceci dans un soucis de "suivit du dossier" ; à J-1 de l'AG, je pense que c'est préférable pour tous.

Hors ligne Marchiavel

Re : Performance du forum
« Réponse #50 le: janvier 21, 2012, 14:01:40 pm »
   Ok, c'est juste pour faire un état d'avancement du problème.

   Je trouve qu'il y a de plus en plus de personnes qui signalent qu'ils le rencontrent et par-dessus tout, au-delà de la gravité du problème lui-même, j'aimerais éviter qu'il ne soit que le symptôme de quelque chose de plus grave (genre si le forum tombe, on s'aperçoit qu'on ne peut pas le remettre en ligne), ou que le problème s'aggrave.

Hors ligne Mandoline

Re : Performance du forum
« Réponse #51 le: janvier 21, 2012, 15:45:54 pm »
le forum est trés trés ralentis, c'est toujours le même soucis?

ou c'est la fédé qui ous attaque la veille de l'AG? :face:
Nobody's perfect, not even Satan's Cheerleaders

Hors ligne Le Yaourt qui parle

Re : Performance du forum
« Réponse #52 le: janvier 21, 2012, 15:48:02 pm »
J'ai le même problème, j'ai du m'y reprendre à 4 fois pour uploader mes corrections à la Newsletter? :S

Bon, c'est pas dramatique, hein, c'est juste pour le signaler (et pour taper sur aifaifjidéherre avec Mando).

Hors ligne Pierstoval

Re : Performance du forum
« Réponse #53 le: janvier 22, 2012, 10:08:29 am »
Kha => Pour la verbosité des logs, tu pourrais à la rigueur voir pour faire un petit script PHP qui ouvre les fichiers logs, affiche leur contenu, et highlight les erreurs 500. Ça t'éviterait d'avoir à tout vérifier à la main... Qu'est-ce que tu en penses ?

Hors ligne Khadamon

Re : Performance du forum
« Réponse #54 le: janvier 22, 2012, 10:11:50 am »
Que nous sommes à J0 de l'AG ^^

C'est jouable mais vu que les logs sont à ouvrir sur un site distant, je sens que cela ne sera pas aussi simple qu'une ouverture de fichier en local.

Hors ligne Marchiavel

Re : Performance du forum
« Réponse #55 le: janvier 22, 2012, 11:07:03 am »
ou c'est la fédé qui ous attaque la veille de l'AG? :face:

   M'étonnerait : leur propre forum est inaccessible :P

Hors ligne ObiWanKennedy

  • Inventeur des soirées pizza, champagne et Chuck Norris. Diplômate, Soigneur d'anémie ferriprive.
  • Floodeur en formation
  • ******
  • Présentation de ObiWanKennedy

  • Messages: 1106
  • Ah Ah! Tu fais moins le malin maintenant
    • Rolisteam
Re : Performance du forum
« Réponse #56 le: janvier 23, 2012, 09:53:37 am »
Normalement sur un server web bien configué les messages d'erreurs et les logs d'acces sont dans des fichiers différents. Typiquement les codes erreurs 500 c'est le serveur web qui déconne donc il va inscrire l'incident dans error.log alors qu'une erreur 400 sera dans acces.log car c'est le client qui demande un fichier inexistant.

Logiciel de JDR Virtuel www.rolisteam.org
__
Licence de mes postes RAB

Hors ligne Darkevil

Re : Performance du forum
« Réponse #57 le: janvier 23, 2012, 09:58:05 am »
Je ne me soucis plus de çà... Chr m'a donné la solution, je fais un F5, çà rafraichit ma page et çà solutionne le problème... :)
Pourquoi n'y ai-je pas pensé avant ! :eek:

Hors ligne Pierstoval

Re : Performance du forum
« Réponse #58 le: janvier 23, 2012, 10:09:14 am »
Que nous sommes à J0 de l'AG ^^

C'est jouable mais vu que les logs sont à ouvrir sur un site distant, je sens que cela ne sera pas aussi simple qu'une ouverture de fichier en local.
Si le gestionnaire fopen est activé, ça devrait pouvoir fonctionner, et pour limiter la mémoire, tu place un paramètre $maxlen(gth) à genre 1000 caractère (ou un peu plus) pour ne récupérer que les dernières erreurs.

S'il n'est pas activé... => FAQ OVH pour voir comment modifier php.ini :)

Hors ligne Nicooo

Re : Performance du forum
« Réponse #59 le: janvier 23, 2012, 13:44:21 pm »
Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

Alors que j'avais poster un truc d'au moins 20 lignes ... si si c'est vrai.
Bon ok ca veu dire plus de fautes dans le post

A 13h40

Gros casse couille devant le grand Cthulhu